U.S. Flag Official website of the Department of Homeland Security
U.S. Department of Homeland Security Seal. ICS-CERT. Industrial Control Systems Cyber Emergency Response Team.

Advisory (ICSMA-18-037-01)

Vyaire Medical CareFusion Upgrade Utility Vulnerability

Original release date: February 06, 2018

Legal Notice

All information products included in http://ics-cert.us-cert.gov are provided "as is" for informational purposes only. The Department of Homeland Security (DHS) does not provide any warranties of any kind regarding any information contained within. DHS does not endorse any commercial product or service, referenced in this product or otherwise. Further dissemination of this product is governed by the Traffic Light Protocol (TLP) marking in the header. For more information about TLP, see http://www.us-cert.gov/tlp/.


Independent researcher Mark Cross (@xerubus) has identified an uncontrolled search path element vulnerability in Vyaire Medical’s CareFusion Upgrade Utility application. Vyaire Medical has produced an update that mitigates this vulnerability.


The following versions of CareFusion Upgrade Utility, designed to upgrade compatible units to the latest software versions, are affected:

  • CareFusion Upgrade Utility used with Windows XP systems, Versions and prior versions.


Successful exploitation of this vulnerability may allow an attacker to insert a malicious DLL on the target system and run arbitrary code.

Impact to individual organizations depends on many factors that are unique to each organization. NCCIC recommends that organizations evaluate the impact of this vulnerability based on their operational environment and specific clinical usage.


Vyaire Medical is a U.S.-based company.

The affected product, CareFusion Upgrade Utility, is designed to upgrade compatible units to the latest software versions. According to Vyaire Medical, CareFusion Upgrade Utility is deployed across the Healthcare and Public Health sector. Vyaire Medical estimates these products are used primarily in the United States and Europe, with a small percentage in Asia.



A successful exploit of this vulnerability requires the local user to install a crafted DLL on the target machine. The application loads the DLL and gives the attacker access at the same privilege level as the application.

CVE-2018-5457 has been assigned to this vulnerability. A CVSS v3 base score of 6.7 has been assigned; the CVSS vector string is (AV:L/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H).



This vulnerability is not remotely exploitable.


No known public exploits specifically target this vulnerability.


High skill level is needed to exploit.


Vyaire Medical is no longer supporting the CareFusion Upgrade Utility v2.0.2.2 and recommends that users upgrade to the newer Vyaire Upgrade Utility v2.0.3.0. This updated Upgrade Utility will not install on Windows XP and will require updating the underlying system to Windows 7 or later.

Vyaire Medical has released a Product Security Bulletin, available at the following URL:


The Vyaire Upgrade Utility v2.0.3.0 update is available at the following URL:


NCCIC recommends that users take defensive measures to minimize the risk of exploitation of this vulnerability. Specifically, users should:

  • Do not upload and run untrusted files without verifying the integrity of the file.
  • Interact with, and only obtain files, software, and software patches from trustworthy highly reputable sources.
  • Ensure that employees with access to the CareFusion Upgrade Utility are fully aware of the ongoing potential for social engineering attacks and are trained to identify and avoid social engineering attacks.
  • Minimize network exposure for all control system devices and/or systems, and ensure that they are not accessible from the Internet.
  • Locate control system networks and remote devices behind firewalls, and isolate them from the business network.
  • When remote access is required, use secure methods, such as Virtual Private Networks (VPNs), recognizing that VPNs may have vulnerabilities and should be updated to the most current version available. Also recognize that VPN is only as secure as the connected devices.

NCCIC reminds organizations to perform proper impact analysis and risk assessment prior to deploying defensive measures.

NCCIC also provides a section for control systems security recommended practices on the ICS-CERT web page. NCCIC reminds organizations to perform proper impact analysis and risk assessment prior to deploying defensive measures.

Additional mitigation guidance and recommended practices are publicly available in the NCCIC Technical Information Paper, ICS-TIP-12-146-01B--Targeted Cyber Intrusion Detection and Mitigation Strategies, that is available for download from the ICS-CERT web site.

Organizations observing any suspected malicious activity should follow their established internal procedures and report their findings to NCCIC for tracking and correlation against other incidents.

Previous Recommendations can be used as needed (otherwise, delete this text). List other products that are specific to the topic (i.e., phishing mitigations):

In addition, NCCIC recommends that users take the following measures to protect themselves from social engineering attacks:

Contact Information

For any questions related to this report, please contact the NCCIC at:

Toll Free: 1-888-282-0870

For industrial control systems cybersecurity information:  http://ics-cert.us-cert.gov 
or incident reporting:  https://ics-cert.us-cert.gov/Report-Incident?

The NCCIC continuously strives to improve its products and services. You can help by choosing one of the links below to provide feedback about this product.

Was this document helpful?  Yes  |  Somewhat  |  No

Back to Top